I have got BeagleBoard C3

In the morning I got text message from DHL courier with request to contact about package. This was total surprise as I did not had idea what it can be…

Few minutes ago package arrived and I now I finally know what it is and who sent it. It is brand new BeagleBoard C3 (so newest version) from German division of Texas Instruments. Why I got it? It is not written anywhere in package… I know that I am not the only one — Nils also got such package.

What will I do with it? For start I will replace B7 version which I got from Bug Labs with C3 to get USB EHCI port working instead of my hacked OTG cable. In next week I will get some extra hardware for it so it will be more in use that B7 is now.

I think that I will try to stack B7 with C3 with BeagleBUG module — but this will make my current case for BB obsolete ;(

It was looking like board is broken:

Texas Instruments X-Loader 1.4.2 (Feb 19 2009 - 12:01:24)
Reading boot sector
Loading u-boot.bin from mmc

U-Boot 2009.01-dirty (Feb 19 2009 - 12:23:21)

I2C:   ready
OMAP3530-GP rev 2, CPU-OPP2 L3-165MHz
OMAP3 Beagle board + LPDDR/NAND
DRAM:  256 MB
NAND:  256 MiB
Using default environment

MUSB: using high speed
In:    serial usbtty
Out:   serial usbtty
Err:   serial usbtty

Texas Instruments X-Loader 1.4.2 (Feb 19 2009 - 12:01:24)

Never mind did I load U-Boot from SD card or from NAND the situation was the same — reset loop…

The solution? Throw away usb cable, connect BB to direct port instead of hub or use external AC to provide power. Now board boots and works fine.

3 thoughts on “I have got BeagleBoard C3

  1. Pingback: 2009 Timeline – Marcin Juszkiewicz

Comments are closed.

  1. [...] iPod connector took it place. Too bad that BUGdock is not possible to buy (FCC not certified etc).got third BeagleBoard — this time from Texas Instruments Germany. I think that I won it during LinuxTag.OctoberI am [...]