Prism firmware features

WiFi cards which use Prism chipset can have miscelanous versions of firmware. Hopefully they can be flashed to newer version — this page have instructions how to make it.

But which version to choose? I tried to collect some infos about firmwares and here are results:

  • 1.3.1- Added ability to perform non-destructive AP scanning (i.e., maintain current association state)
  • 1.4.9 — Earlier version (1.4.2?) has some problems with PCI-based cards. The symptom is corrupted packets. If you have PCI cards, upgrade to this one.
  • 1.5.6 — This version and later ones enable hostap driver to use standard 4-address packet format for WDS packets.
  • 1.6.3 — Supports hiding ESSID.
  • 1.7.0 — Supports WPA encryption.
  • 1.8.4 — Latest flashable version.